All posts

Ruby no preset version installed asdf

The issue I faced here was:

  1. I installed a new version of ruby
  2. I added that version to my .tool-versions file
  3. I tried to run the application and was faced with the error No preset version installed for ...

I imagine others will face this issue with different plugins, but the answer for me was to reshim so that the exectuables were created for the Ruby version I wanted to use:

asdf reshim ruby 2.5.6

After that I was able to run ruby executables for Rbuy 2.5.6.

Postscript:

I built two products to help fund continued efforts for this website, it would mean a lot if you would check them out:
1. 2500+ Words for the Undermotivated Software Engineer - A short essay I wrote on the titled topic ($3).
2. Build 3 Chrome Extensions in Under 2 Hours - A course I built to teach chrome extension development ($9-20).